via Linux worm targets PHP flawDon’t Panic! WordPress is Secure

That is incorrect. WordPress 1.5 or higher is safe. Since the release of version 1.5, WordPress has used a completely different XML-RPC library, called IXR.

Older WP versions (1.2.x and earlier) are vulnerable, however. If for some reason you are still running a pre-1.5 version of WordPress, you should upgrade immediately to the latest version, WordPress 1.5.2 “Strayhorn”. If upgrading poses a problem for some reason, and if you don’t need pingbacks or blog client API functionality, simply delete the class-xmlrpc.php and class-xmlrpcs.php files from your installation’s wp-includes directory (but you really should upgrade).

WP1.5以上を使ってる分には上記の脆弱性で取り上げられているXML-RPCとは違うXML-RPCライブラリを使っているため問題無いみたい。問題なのは1.2.x以下のバージョンだそうです。pingback や ブログクライアントAPIを使わない方に限る応急処置としては /wp-inclueds/class-xmlrpc.php/wp-inclueds/class-xmlrpcs.php を削除する事だそうです。でも早急に1.5以上のバージョンへアップグレードしなさいといってます。