久しぶりにデスクトップピクチャのスクリーンショットをアップロードしようとしたら気付いた次第。2.0.6 にver.upしてからこうなったのでおそらく2.0.6が問題だとは思いますが,果たして 😕

以下のように post.php にソースは記述されてはいるのですが,Camino も Safari も iframe をサポートしていないブラウザだと認識されているようです,多分
<iframe id="uploading" frameborder="0" src="inline-uploading.php?action=view&post=-1168664400&_wpnonce=485f05f6c8">This feature requires iframe support.</iframe>

ということで,こういう時のための Flickr(?!)
inline-uploading.php is missing

他のサーバへ 2.0.6をアップグレードでインストールしたところ問題なく inline-uploading.php の iframe 部分が表示されているので,おそらくここのサーバ/ファイル/設定の問題かと思われます。もう1回ファイルを上書きしてみようかなー。

その後 2006-01-14 5:54pm 追記

hiromasa さんと Skype で wp-megaten の事を話しながらこのトラブルの事を相談したところ,以下のような返答が:

  1. ここ最近入れたプラグインの中で,ソースファイルの一番先頭に記述されている >?php より前,または一番最後に記述されている ?
    >
    より後にスペースや空行があるかどうか見て欲しい
  2. あと,関係はないかも知れないけど,feed の1行目に空行ができてて syntax error がでているのでチェックしてみて下さい

という事で,/wp-content/plugin/以下にあるファイルを全部ダウンロードし,テキストエディタで確認/修正をしました。
このような修正を施したところ,
inline-uploading.php is comming!

開いた総ファイル数は300近くになり,なかなか泣ける作業になりました :[
hiromasa さん,ありがとう!

教訓

プラグインをアップロードする前に文字コード,改行コード,EOF 直前の空行には気をつけましょう。