Habari

昨日 kohakuさんから教わってダウンロードしてみました。WordPress のブランチ(?)みたいなものだそうです。聞くところによると,インストールに成功したのは tai さんだけだとか。

サーバの要求環境を見てみると,

  • Sup­por­ted Web Server 
    • Apache 2
    • Light­tpd
  • Sup­por­ted Data­base
    • MySQL 4.1.x or great­er
    • SQL­ite
  • PHP ver­sion 5 
    • PHP Data Objects (PDO) enabled
    • Sim­pleXML enabled

from Install­a­tion – Habari Pro­ject

国内の,割りといい環境のサーバなら満たせる環境なんじゃなかろうかと思います。とはいえ,Apache 2 というのがちょっと提供があるかどうかわかりませんが…。レガシーな環境をバッサリ切り捨てた,これからのサーバサイドスクリプトという印象が強いです。

kohak­uさんに入れてみてよーといわれて色々探してみたところ,Google の Habari usersの一人は私も使っている Blue­Host へのインストールが成功したようです。どんな設定をしたのか見てみると,

Habari requires PHP5 and PDO (for data­base access). On Blue­host, the fol­low­ing lines must be added to ‘php.ini’ to activ­ate the PDO drivers for mySQL.
extension=pdo.so
extension=pdo_mysql.so

from Fun with Habari

ルートディレクトリにある php.ini へ
extension=pdo.so
extension=pdo_mysql.so

を追記しろという事だそうです。 PDO を MySQL へ関連付けるといったところなんでしょうか? (デフォルトでは phpin­foにある PDO の値は sql­lite2 になっていました)
早速 php.ini を書き換えてみたところ,PDO の値は sql­lite2 のまま。インストーラを起動させてもcould not find driver というエラーがでて先に進まず。エラーを検索しても PDO が MySQL に関連付けられていないんじゃないのか的なフォーラムの回答が引っ掛かるのみ。実際,PDO の値は上記の通り sql­lite2 のままなので何とかしてこれを MySQL に変えさせたいところです。上のブログの作者に聞いてみた方が良いのかも知れません.…。